Search results

  1. KeesB

    1971 Rover 2000 SC

    Beautiful car. Interesting to see the mix of new and old style switches for lights and wipers.
  2. KeesB

    Tobacco leaf 3500

    In the end it was the reserve tap causing the problem. At the end of August I have got him MOT´d and did some 180 mls without any problems.
  3. KeesB

    New Dutch member.

    Hallo Jan, Het wordt steeds drukker met Nederlanders hier :) Regards, Kees
  4. KeesB

    Tobacco leaf 3500

    Thanks for the tips John. I have tried the reserve tap and it was not completely in the right position. I hope this was the problem but did not have time yet for a test drive. Hope to do that this week. I will keep you posted.
  5. KeesB

    Tobacco leaf 3500

    Last december I bought a 1975 P6 3500 automatic in Tobacco leaf. The MOT was expired but it was driveable. A few weeks ago I have started to get it ready for MOT. The parking brake did not work and when I investigated it turned out the brake pads were very worn so I have changed these. Such a...
  6. KeesB

    1969 3500 Series 1 in April Yellow

    Great, beautiful car.
  7. KeesB

    Rover 2200SC - MRW 392P

    Very nice car.
  8. KeesB

    3500S

    Hello Joop, welcome and nice to see another Dutchman here. Regards, Kees
  9. KeesB

    A Rover In The Garage

    He drove a Mini in the 60´s.
  10. KeesB

    Rye, just now - who was that?

    Rye is lovely, we have been there very often. Are you also going to Hastings? That is nice too :D Kees
  11. KeesB

    Vanden Plas Automatic 1982

    She drives very well. I haven´t used it very much but I plan to take it to England this summer. With 3 kids and luggage in the back she will be lowered!
  12. KeesB

    FITTING OF SPARE WHEEL ON BOOT?

    Re: FITTING OF SPARE TYRE ON BOOT? Why would you bother fitting the spare on the outside? It spoils the beautiful lines of the P6 and you can´t see in the rearview mirror. The spare of mine is in the boot and I have been on holiday in England with the P6 several times already with 2 adults and...
  13. KeesB

    New member, 1972 3500S

    Welcome here. Nice to see another Dutchman :D
  14. KeesB

    New addition

    From a former owner I learned that in the past headlight washers were fitted. The reservoir is still visible under the bonnet, so I have to re-install them.
  15. KeesB

    Vanden Plas Automatic 1982

    Bought last week:
  16. KeesB

    New addition

    Some new pictures:
  17. KeesB

    New addition

    I just picked her up yesterday evening so could not take any pictures. I will try and make some this weekend. Regards, Kees
  18. KeesB

    New addition

    Today I have bought a new addition to my fleet. It is a 1982 Rover 3500 Vanden Plas Auto. After having sold my Saab 900 there was a place to fill :D
  19. KeesB

    Time to say goodbye ?

    It would be a shame to see your P6 go, it is a really beautiful car (even in a muddy New Forest :D ). On the other hand I do understand your choice for een Saab 900 because they are a great drive and feel very solid and modern (I only just sold mine because having 9 (!!) cars was a bit to...
  20. KeesB

    new members series1 pics

    Beautiful car, I really like the series one. It is the only one I would consider instead of my 1964 car.
  21. KeesB

    Happy birthday GH-48-73

    Today it is exactly 50 years ago my P6 was made :D . Will it still be around in another 50 years? Regards, Kees
  22. KeesB

    And another MOT failure, now passed!

    Hooray, the P6 passed his MOT, only one day late :D . Next MOT in october 2016.
  23. KeesB

    Members ages

    I am 49 and my P6 is one year older then I am :D Kees
  24. KeesB

    And another MOT failure, now passed!

    Re: And another MOT failure This weekend I have replaced the rear wheel bearing. What a terrible job :evil: I have changed wheel bearings on Mini´s, Maxi´s, Allegro´s, etc but never had the strange construction Rover designed. The make it look easy in the workshop manual but you have to put a...
  25. KeesB

    And another MOT failure, now passed!

    Last friday my ´64 P6 failed its MOT for the first time in 5 years :cry: First just before it went into the service bay the indicators stopped working (they were fine on the way to the MOT station). It turned out to be a bad connection at the fuse which I could easily repair. The MOT went fine...
Top